Mitel Performance Analytics (MPA) Upgrade - UK Flex Instance

Scheduled for Jul 30, 20:00 - 21:00 UTC

Update

We will be undergoing scheduled maintenance during this time.
Posted Jul 23, 2026 - 14:55 UTC

Scheduled

Mitel's 3rd Party Vendor will be upgrading the MPA Instance (mpa-eu.flex.gc.mitel.io). During the upgrade there will be no access to the MPA dashboard.
This maintenance has no impact to active Voice Services or VM Infrastructure.
The work will start at 20:00 UTC on Thursday 30th July
Posted Jul 21, 2026 - 20:16 UTC
This scheduled maintenance affects: EMEA (Mitel Performance Analytics (FlexEU)).