Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 23, 2025 - 15:00 UTC
Scheduled
Mitel 3rd Party Vendor Schedule Maintenance – Dallas
11:11 Engineering will be upgrading the 11:11 Secure DRaaS with Zerto infrastructure. This latest vendor upgrade incorporates significant bug fixes and enhancements for all customers currently utilizing this service.
Expected Impact:
During this maintenance, modifications to VPG configurations, replication and all failover activities will be unavailable.
Customers are required to stop all failover tests prior to this maintenance window and may see an intermittent site disconnect status.
Maintance Window
Start Date & Time: 23/10/2025 15:00:00 UTC End Date & Time: 23/10/2025 21:00:00 UTC
Posted Oct 20, 2025 - 00:52 UTC
This scheduled maintenance affected: North America (Dallas - MiCloud Flex Virtual Compute Environment).