Secondary Power issues in London Data Center CoLocation

Incident Report for Global Flex Status

Resolved

This incident has been resolved . Power restored to all single PSU devices
Posted Aug 11, 2026 - 22:11 UTC

Update

We are continuing to work on a fix for this issue.
Posted Aug 11, 2026 - 21:34 UTC

Update

We are continuing to monitor the issue - services are impacted for just one Partner using 81.131.58.x Public IP range.
This is due to a Partner owned router having a single power supply.
We are attempting to manually patch power over to primary feed.
Posted Aug 11, 2026 - 21:33 UTC

Identified

Currently we are experiencing an issue with Secondary Power into our London DC CoLocation.
This is affecting some Customer/Partner delivered equipment that has only one power supply provisioned.
It appears to be affecting only one Partner who have been notified.
Resolution expected within the hour
Posted Aug 11, 2026 - 20:50 UTC
This incident affected: EMEA (London - MiCloud Flex Services Network Connectivity).