Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 24, 2026 - 22:00 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 24, 2026 - 15:06 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 21, 2026 - 12:28 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted Aug 20, 2026 - 00:01 UTC
Scheduled
Mitel will be manually switching network equipment from PDU A to PDU B in preparation for a scheduled maintenance the following night where the PDU A power supply will be isolated for Annual Electrical testing. This maintenance will affect only those Customer/Partner Devices that gave only one physical power supply installed. The affected devices will power cycle for approx 10 minutes, at which time any services connected through said device will be down. The total window is set for 1 hours
The maintenance window has now moved to 22:00 UTC - 23:00 BST