Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 13, 2025 - 07:00 UTC
Scheduled
Summary: As part of on-going maintenance, Engineering will be performing OS patching in the Cloud Backup and DRaaS environments. Impact: During this maintenance window, the Cloud Backup services will be offline and customers using Secure DRaaS products may see intermittent site disconnects and will be unable to perform operations on protected virtual machines. We also require failover tests to be stopped during the maintenance. We do not expect any impact to running or protected virtual machines during this maintenance. Customer Action: There is no action required. All services will resume as normal at the end of the maintenance window.
Posted May 01, 2025 - 18:14 UTC
This scheduled maintenance affected: EMEA (Manchester - MiCloud Flex Services Network Connectivity) and North America (Dallas - MiCloud Flex Services Network Connectivity).